Pip install failed when running experiments on the cloud


#1

I got an error during running an experiment on the cloud. It seems that the pip version is not compatible to the steppy lib, any idea about how to fix this? Is that possible to upload my own docker images to the cloud?
Error messages:

13.45613 [pip] Could not find a version that satisfies the requirement ipython>=6.4.0 (from steppy==0.1.4->-r requirements.txt (line 3)) (from versions: 0.10, 0.10.1, 0.10.2, 0.11, 0.12, 0.12.1, 0.13, 0.13.1, 0.13.2, 1.0.0, 1.1.0, 1.2.0, 1.2.1, 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 3.0.0, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 4.0.0b1, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.1.0rc1, 4.1.0rc2, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.2.1, 5.0.0b1, 5.0.0b2, 5.0.0b3, 5.0.0b4, 5.0.0rc1, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.3.0, 5.4.0, 5.4.1, 5.5.0, 5.6.0, 5.7.0)
13.456249 [pip] No matching distribution found for ipython>=6.4.0 (from steppy==0.1.4->-r requirements.txt (line 3))
13.456375 [pip] You are using pip version 9.0.1, however version 10.0.1 is available.
13.456495 [pip] You should consider upgrading via the ‘pip install --upgrade pip’ command.

#2

Hi @yang.niceday!

ipython==6.4.0 requires Python 3.

From https://ipython.readthedocs.io/en/stable/whatsnew/version6.html :

Beginning with version 6.0, IPython stopped supportingcompatibility with Python versions lower than 3.3 including all versions of Python 2.7.

Please try running your experiment on a Python 3 environment.

Best,
Piotr