Version 2.8.0 - Cannot login from terminal

solved

#1

Hi everyone,
I need to use the neptune-cli from a remote VM but after the last update the login process changed and it requires a browser in the same machine. I tried to use the NEPTUNE_MANUAL_LOGIN=true flag, and I manage to get the token from the url but after pasting it nothing happens.

Is there a way to login on a remote VM using the terminal?

Thank you in advance for your help,
Giacomo


#2

Hi @gezzig,

What do you exactly execute in your terminal inside a VM?

It should be:

$ export NEPTUNE_MANUAL_LOGIN=true
$ neptune account login

I checked it a moment before and the CLI logged me in successfully.

Best regards,
Dominik


#3

Hi @dominik.jastrzebski,
thanks for the reply.

I did exactly the same thing but after pasting the token and pressing ENTER the cli does not print or do anything.
I have also reinstalled the neptune-cli but it did not solve the problem.

Regards,
Giacomo


#4

@gezzig Please make sure that you have internet connection in your VM and it can “see” Neptune.

You can check that with:
$ ping auth.neptune.ml


#5

@dominik.jastrzebski the VM reaches your auth server.

$ ping auth.neptune.ml
PING auth.neptune.ml (35.186.223.74) 56(84) bytes of data.
64 bytes from 74.223.186.35.bc.googleusercontent.com (35.186.223.74): icmp_seq=1 ttl=49 time=0.532 ms
64 bytes from 74.223.186.35.bc.googleusercontent.com (35.186.223.74): icmp_seq=2 ttl=49 time=0.522 ms
64 bytes from 74.223.186.35.bc.googleusercontent.com (35.186.223.74): icmp_seq=3 ttl=49 time=0.516 ms

#6

@gezzig Possibly the issue is related to your firewall configuration. Please try this on your VM:

curl https://euclid.neptune.ml/version

to check whether HTTP requests to Neptune are allowed.


#7

@dominik.jastrzebski I guess they are allowed. This is the output:

$ curl https://euclid.neptune.ml/version
{"version":"2.8.0","commitId":"cde42f223b5787ff4defaa19d9fcbf2c66e09487","buildDate":"2018-04-23 15:11:23.830"}

#8

@dominik.jastrzebski thanks for your help. I tried on a different machine and I do not have the problem. So, I think there is something wrong on the first VM. Thank you again.

Giacomo


#9

@gezzig Good to hear that you got your setup working! :slight_smile: