Update to PyTorch 0.3


#1

Is it possible to get a PyTorch 0.3 environment? (I.e. the newest version.)


#2

Hi, I see no problem here as pytorch 0.3.1 is compiled against cuda 80. But you will need to wait for the next release.


#3

In the meantime you can start base or base-gpu environments and use pip requirements mechanism (https://docs.neptune.ml/config/experiment/#pip-requirements-file).

File for cpu with Python2:

http://download.pytorch.org/whl/cpu/torch-0.3.1-cp27-cp27mu-linux_x86_64.whl
torchvision

File for cpu with Python3:

http://download.pytorch.org/whl/cpu/torch-0.3.1-cp36-cp36m-linux_x86_64.whl
torchvision

File for gpu with Python2:

http://download.pytorch.org/whl/cu80/torch-0.3.1-cp27-cp27mu-linux_x86_64.whl
torchvision

File for gpu with Python3:

http://download.pytorch.org/whl/cu80/torch-0.3.1-cp36-cp36m-linux_x86_64.whl
torchvision